2. Platform Compatibility

You are here:
← All Topics

AntiSocial Knowledge Lab is designed with a wide range of users in mind. All we ask is that you are on a modern device with either a Chrome or Safari browser. Other browsers and older devices might still work with the platform, but they are not supported or included in our user testing processes.

For optimal performance we recommend the following settings:

  1. Modern Device – iPhone, Apple Mac, iPad. Android Phone or Tablet. laptop or desktop computer.
  2. Updated Operating System – iOS, MacOS, Windows 10, Android or Linux.
  3. Modern Web Browser – Chrome and Safari are supported, other browsers (Edge, Firefox, Opera) are highly likely to function all same.

Download Google Chrome Now:

Android: https://play.google.com/store/apps/details?id=com.android.chrome&hl=en_GB

iOS: https://apps.apple.com/gb/app/google-chrome/id535886823